Home pageFind It!Contact PJAPJA documentation

PJA

 PJA Toolkit forum

This forum is dedicated to PJA Toolkit.
You may read freely the messages it contents. If you want to write a message or answer to a subject, subscribe to it first.

Subjects Recent messages Login Subscribe

Messages of subject configure PJA2.4 on websphere 5.0 and above application servers

pinacle

Location : USA
Member since : Oct 31, 2003
Messages : 1
 Oct 31, 2003 at 5:18 PM
Can any one tell me how to configure PJA2.4 on websphere 5.0 and above application servers

angel

Location : Stuttgart/Germany
Member since : Nov 4, 2003
Messages : 2
 Nov 4, 2003 at 10:39 AM
I have installed pja2.4 on websphere 5.0. You have to set bootclasspath and add some -D parameters.

Choose your server.
Scroll down then you will find the link "process definition" (sorry I dont know exactly how the name is from the link, because I use the german version). Scroll down then you will find the link "java virtual machine". Choose it and you will find an entry field for your bootclasspath. Enter your classpath to pja.jar.
Then you scroll down in this site and you will find the link "user defined properies" (sorry I dont know exactly how the name is from the link, because I use the german version). Choose this link and then you can create your -D parameter for pja (for parameters see documentaion pja). For each parameter one properies like this:
key = awt.toolkit
value = com.eteks.awt.PJAToolkit

Now PJA is installed on websphere 5.

Good luck... :-)

Stef

Location : Vienna, Austria
Member since : Mar 12, 2004
Messages : 1
 Mar 12, 2004 at 5:35 PM
Hi,

I followed your instructions as closely as possible, but I still get the following error message:

<B>Error Message: </B>Could not find class: com.eteks.java2d.PJAGraphicsEnvironment<BR>
<B>Error Code: </B>500<BR>
<B>Target Servlet: </B>null<BR>
<B>Error Stack: </B><BR>
java.lang.Error: Could not find class: com.eteks.java2d.PJAGraphicsEnvironment
<BR>&nbsp;&nbsp;&nbsp;&nbsp;
at java.awt.GraphicsEnvironment.getLocalGraphicsEnvironment&#40;GraphicsEnvironment.java:75&#41;
<BR>&nbsp;&nbsp;&nbsp;&nbsp;
at java.awt.image.BufferedImage.createGraphics&#40;BufferedImage.java:1033&#41;
<BR>&nbsp;&nbsp;&nbsp;&nbsp;
at org.apache.fop.svg.PDFGraphics2D.&lt;init&gt;&#40;PDFGraphics2D.java:1401&#41;
<BR>&nbsp;&nbsp;&nbsp;&nbsp;
at org.apache.fop.render.pdf.PDFRenderer.renderSVGDocument&#40;PDFRenderer.java:638&#41;
<BR>&nbsp;&nbsp;&nbsp;&nbsp;
at org.apache.fop.render.pdf.PDFRenderer.renderSVGArea&#40;PDFRenderer.java:549&#41;
<BR>&nbsp;&nbsp;&nbsp;&nbsp;
at org.apache.fop.svg.SVGArea.render&#40;SVGArea.java:98&#41;
...



The differences to your configuration are:

1) My Bootclasspath looks as follows:

/home/prod/rzbbkl/weblib/xerces-1.2.3.jar;/home/prod/rzbbkl/weblib/xml-apis-2.4.0.jar;/home/prod/rzbbkl/weblib/pja-2.4.jar

I.e. I also have some other JAR files in it. Might this be a problem?

2) My user defined properties are:
awt.toolkit = com.eteks.awt.PJAToolkit
java.awt.graphicsenv = com.eteks.java2d.PJAGraphicsEnvironment

It did not work with the above parameters, so I tried to add some fonts definition too (although I did not expect it would improve there error, and alas, it didn't):
java.awt.fonts = /usr/WebSphere/AppServer5/java/jre/lib/fonts
java2d.font.usePlatformFont = false
user.home = /home/prod/rzbbkl


3) I am using neither pjatools.jar nor servlet.jar

Does anybody have an idea why PJA doesn't work here?

cheers
Stefan

PS It just doesn't work under WAS 5, but it did work very well under WAS 4...


Home pageFind It!ContactTop

© Copyrights 1997-2014 eTeks - All rights reserved

PJAPJA documentation