Home pageFind It!Contact PJAPJA documentation

PJA

 PJA Toolkit forum

This forum is dedicated to PJA Toolkit.
You may read freely the messages it contents. If you want to write a message or answer to a subject, subscribe to it first.

Subjects Recent messages Login Subscribe

Messages of subject PJA & WAS 4.0.5 configuration on UNIX AIX 5.1 :)

modulo2

Location : Egypt
Member since : Dec 17, 2003
Messages : 1
 Dec 17, 2003 at 9:36 AM
Dears,
Thanks too much for this library, u don't know how it solved my problems. I want to contribute my experience with its configuration on WAS (IBM Websphere Application Server) 4.0.5 with others as I tried to get how it is configured from this forum, but all I get was by exporting the WAS configuration and importing it again, so here is how it is done from WAS admin console:

lets assume that my WAS instance is "XYZServer", not the machine host name
and pja.jar, pjatools.jar, fonts.properties are installed on directory "PJA_DIR" as an example "/usr/pja", and JAVA_HOME is "/usr/java131"

Detailed steps:
1- Open WebSphere AppServer admin cosole.
2- Expand the nodes till u reach the application server instance that is hosting yr application "XYZServer".
3- Select "JVM Settings" tab.
4- Click "Advanced JVM Settings".
5- In the "Advanced JVM Settings" dialog, In the "Boot classpath (append)" text box, write the following without double quotes "PJA_DIR/pja.jar", Note: I found that in the "Generated Command Line Arguments" WAS added "/a:" so it is written now "-Xbootclasspath/a:PJA_DIR/pja.jar"
6- In the advanced "Advanced JVM Settings" dialog, In the "Command line arguments:" text box, write the following without double quotes "-Dawt.toolkit=com.eteks.awt.PJAToolkit -Djava.awt.graphicsenv=com.eteks.java2d.PJAGraphicsEnvironment -Djava2d.font.usePlatformFont=false -Djava.awt.fonts=JAVA_HOME/jre/lib/fonts/ -Duser.home=PJA_DIR"
7- Apply changes by clicking "Apply" button.
8- Restart the AppServer instance "XYZServer", No need to restart all the WAS.

Enjoy.

Again thankx for all PJA team.
---
Ashraf Fouad Ayoub
Senior software developer

Manu

Location : Paris / France
Member since : Apr 29, 2003
Messages : 394
 Jan 7, 2004 at 12:26 AM
Thank you wery much for your contribution.
---
Manu (moderator/modérateur)

petem10

Location : UK
Member since : Apr 20, 2004
Messages : 2
 Apr 20, 2004 at 10:44 AM
Have followed the advice above (http://www.eteks.com/pja/en/forum/viewSubject.jsp?subjectId=236) but still have problems.

What JDK were you using modulo2?
I have jdk 1.3.1 does this make a difference?

The error below happens when my first class is encountered that needs any java2d packages which is embedded in barfragment.jsp.

This looks like a Xbootclasspath problem, can anyone help ?

Thanks
Pete

+++++++++++++++++++++++++++++++++++++++++++++++++++++++

X Servlet Error: Could not find class: com.eteks.java2d.PJAGraphicsEnvironment: java.lang.Exception: Could not find class: com.eteks.java2d.PJAGraphicsEnvironment
at cps103.JSP._barfragment_jsp_1._jspService(_barfragment_jsp_1.java:94)
at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:142)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
at org.apache.jasper.runtime.JspServlet$JspServletWrapper.service(JspServlet.java:323)
at org.apache.jasper.runtime.JspServlet.serviceJspFile(JspServlet.java:503)
at org.apache.jasper.runtime.JspServlet.service(JspServlet.java:636)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
at com.ibm.servlet.engine.webapp.StrictServletInstance.doService(ServletManager.java:827)
at com.ibm.servlet.engine.webapp.StrictLifecycleServlet._service(StrictLifecycleServlet.java:167)
at com.ibm.servlet.engine.webapp.IdleServletState.service(StrictLifecycleServlet.java:297)
at com.ibm.servlet.engine.webapp.StrictLifecycleServlet.service(StrictLifecycleServlet.java:110)
at com.ibm.servlet.engine.webapp.ServletInstance.service(ServletManager.java:472)
at com.ibm.servlet.engine.webapp.ValidServletReferenceState.dispatch(ServletManager.java:1012)
at com.ibm.servlet.engine.webapp.ServletInstanceReference.dispatch(ServletManager.java:913)
at com.ibm.servlet.engine.webapp.WebAppRequestDispatcher.handleWebAppDispatch(WebAppRequestDispatcher.java:721)
at com.ibm.servlet.engine.webapp.WebAppRequestDispatcher.dispatch(WebAppRequestDispatcher.java:374)
at com.ibm.servlet.engine.webapp.WebAppRequestDispatcher.forward(WebAppRequestDispatcher.java:118)
at com.ibm.servlet.engine.srt.WebAppInvoker.doForward(WebAppInvoker.java:134)
at com.ibm.servlet.engine.srt.WebAppInvoker.handleInvocationHook(WebAppInvoker.java:239)
at com.ibm.servlet.engine.invocation.CachedInvocation.handleInvocation(CachedInvocation.java:67)
at com.ibm.servlet.engine.srp.ServletRequestProcessor.dispatchByURI(ServletRequestProcessor.java:151)
at com.ibm.servlet.engine.oselistener.OSEListenerDispatcher.service(OSEListener.java:315)
at com.ibm.servlet.engine.http11.HttpConnection.handleRequest(HttpConnection.java:60)
at com.ibm.ws.http.HttpConnection.readAndHandleRequest(HttpConnection.java(Compiled Code))
at com.ibm.ws.http.HttpConnection.run(HttpConnection.java(Compiled Code))
at com.ibm.ws.util.CachedThread.run(ThreadPool.java:138)

sakthi

Location : chennai, India
Member since : Dec 21, 2010
Messages : 1
 Dec 21, 2010 at 5:54 AM
Thank you very much for a such a clear explanation.
---
sakthi


Home pageFind It!ContactTop

© Copyrights 1997-2014 eTeks - All rights reserved

PJAPJA documentation