Home pageFind It!Contact PJAPJA documentation

PJA

 PJA Toolkit forum

This forum is dedicated to PJA Toolkit.
You may read freely the messages it contents. If you want to write a message or answer to a subject, subscribe to it first.

Subjects Recent messages Login Subscribe

Messages of subject AbstractMethodError when running ToolkitDemo

Matthias

Member since : Jan 16, 2004
Messages : 5
 May 17, 2004 at 10:33 AM
Hi,

I have used PJA on several machines now and it works perfectly. However I've just installed it on a new machine and it doesn't work there. When I start PJAToolkitDemo1.2.sh, the output is:

Toolkit demo
© Copyright 2000-2001 eTeks <info@eteks.com>.
© Copyright 1996,1998 by Jef Poskanzer <jef@acme.com>.

Toolkit class in use is com.eteks.awt.PJAToolkit
Exception in thread "main" java.lang.AbstractMethodError: sun.java2d.SunGraphicsEnvironment.createFontProperties()Lsun/awt/FontProperties;
at sun.java2d.SunGraphicsEnvironment$1.run(SunGraphicsEnvironment.java:131)
at java.security.AccessController.doPrivileged(Native Method)
at sun.java2d.SunGraphicsEnvironment.<init>(SunGraphicsEnvironment.java:85)
at com.eteks.java2d.PJAGraphicsEnvironment.<init>(PJAGraphicsEnvironment.java:66)
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
at java.lang.reflect.Constructor.newInstance(Constructor.java:274)
at java.lang.Class.newInstance0(Class.java:308)
at java.lang.Class.newInstance(Class.java:261)
at java.awt.GraphicsEnvironment.getLocalGraphicsEnvironment(GraphicsEnvironment.java:62)
at java.awt.Window.init(Window.java:231)
at java.awt.Window.<init>(Window.java:275)
at java.awt.Frame.<init>(Frame.java:401)
at java.awt.Frame.<init>(Frame.java:366)
at ToolkitDemo$ImageBuilder.createImage(ToolkitDemo.java:190)
at ToolkitDemo.ComputeImageFiles(ToolkitDemo.java:138)
at ToolkitDemo.main(ToolkitDemo.java:120)

The Java version is 1.4.2_04, the OS is SunOS 5.8.
Any ideas what's going wrong?

Thanks,
Matthias

brihaye

Location : Rennes / France
Member since : Apr 15, 2004
Messages : 9
 May 17, 2004 at 11:32 AM
Did you have a look at :

http://www.eteks.com/pja/en/forum/viewSubject.jsp?subjectId=99

Cheers,

p.b.

Matthias

Member since : Jan 16, 2004
Messages : 5
 May 17, 2004 at 6:14 PM
It works now, thank you very much!

Matthias


Home pageFind It!ContactTop

© Copyrights 1997-2014 eTeks - All rights reserved

PJAPJA documentation