Home pageFind It!Contact PJAPJA documentation

PJA

 PJA Toolkit forum

This forum is dedicated to PJA Toolkit.
You may read freely the messages it contents. If you want to write a message or answer to a subject, subscribe to it first.

Subjects Recent messages Login Subscribe

Messages of subject The holy grail, yet nothing happens

marilenc

Member since : Jan 23, 2006
Messages : 1
 Jan 23, 2006 at 4:28 PM
Hello,

I am having a large web application which uses javaio for image manipulation: tomcat + java 1.4.2_08 on a debian machine, no X libraries what so ever. I tried to configure pja and yet nothing happens. Also created a simplet test program:

import javax.imageio.ImageIO;
import java.awt.image.BufferedImage;
import java.io.File;
import java.util.Properties;
import java.util.Enumeration;

public class TestJIO {
public static void main(String[] args) throws Exception{
File file = new File(args[0]);
BufferedImage img = null;
img = ImageIO.read(file);
}
}

and running everything with:

java -Xbootclasspath/a:/usr/local/pja/lib/pja.jar -Dawt.toolkit=com.eteks.awt.PJAToolkit -Djava.awt.graphicsenv=com.eteks.java2d.PJAGraphicsEnvironment -Djava.awt.fonts=$JAVA_HOME/jre/lib/fonts -cp . TestJIO pgeneral.gif

yet I get the following error:

Exception in thread "main" java.lang.UnsatisfiedLinkError: /usr/local/j2sdk1.4.2_08/jre/lib/i386/libawt.so: libXp.so.6: cannot open shared object file: No such file or directory
at java.lang.ClassLoader$NativeLibrary.load(Native Method)
at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1586)
at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1503)
at java.lang.Runtime.loadLibrary0(Runtime.java:788)
at java.lang.System.loadLibrary(System.java:834)
at sun.security.action.LoadLibraryAction.run(LoadLibraryAction.java:50)
at java.security.AccessController.doPrivileged(Native Method)
at java.awt.image.ColorModel.loadLibraries(ColorModel.java:188)
at java.awt.image.ColorModel.<clinit>(ColorModel.java:196)
at javax.imageio.ImageTypeSpecifier$Packed.<init>(ImageTypeSpecifier.java:275)

What am I doing wrong?

Thank you,
Len

Manu

Location : Paris / France
Member since : Apr 29, 2003
Messages : 394
 Jan 25, 2006 at 2:31 AM
As far as I know libawt.so relies on X11 libs in JDK 1.4 ; I think you should miserably add them on the server or use JDK 1.5. Please read http://www.eteks.com/pja/en/forum/viewSubject.jsp?subjectId=38 for more information.
---
Manu (moderator/modérateur)

DaveBartrum

Member since : Jan 9, 2008
Messages : 1
 Jan 9, 2008 at 11:22 AM
We had similar error in our Weblogic application, trying to invoke JFreeChart service. Even when we'd loaded libXp.so.6 onto the server.

Weblogic expected to find the file in:
/opt/weblogic/weblogic810sp6/jrockit81sp6_142_10/jre/lib/i386/libXp.so.6

So we created a symbolic link there which points to
/usr/X11R6/lib/libXp.so.6, which itself is a symbolic link to
/usr/X11R6/lib/libXp.so.6.2

On a different server, the real libXp.so.6.2 file was loaded into /usr/X11R6/lib64/libXp.so.6 and we had a breakdown in the chain of symbolic links, which reports the same error, i.e.

javax.faces.FacesException: #{ViewGraphForPSS.cdlViewGraphForPSSAction}: javax.faces.el.EvaluationException: java.lang.UnsatisfiedLinkError: /opt/weblogic/weblogic810sp6/jdk142_11/jre/lib/i386/libawt.so: libXp.so.6: cannot open shared object file: No such file or directory


Home pageFind It!ContactTop

© Copyrights 1997-2014 eTeks - All rights reserved

PJAPJA documentation